$re = '/(^(.*):)/m';
$str = '14:15
14:2
10:2
1:20
1:5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);