$re = '/\|(.*)\]/';
$str = '[id11115441|Андрей], врать вредно, голубчик. Экологи добивались ...';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);