re = /\|(.*)\]/
str = '[id11115441|Андрей], врать вредно, голубчик. Экологи добивались ...'
# Print the match result
str.match(re) do |match|
puts match.to_s
end