import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)LEVEL:\\s+(?<LEVEL>.*)PID\\s+:\\s(?<PID>\\d+)\\s+TID\\s:\\s+(?<TID>\\d+)\\s+PROC\\s+:\\s+(?<PROC>\\w+)\\s+\\d+\\s+INSTANCE:\\s+(?<INSTANCE>\\w+)\\s+NODE\\s+:\\s+(?<NODE>\\d+)\\s+DB\\s+:\\s+(?<DB>\\w+)\\s+APPHDL\\s+:\\s+(?<APPHDL>[^ ]+)\\s+APPID:\\s+(?<APPID>[^ ]+)UOWID\\s+:\\s+(?<UOWID>\\d+)\\s+ACTID:\\s+(?<ACTID>\\d+)\\s+AUTHID\\s+:\\s+\\w+\\s+HOSTNAME:\\s+(?<HOSTNAME>[^ ]+)\\s+EDUID\\s+:\\s+(?<EDUID>\\d+)\\s+EDUNAME:\\s+(?<EDUNAME>.*)\\s+FUNCTION:\\s+(?<FUNCTION>\\w+)";
final String string = "2020-01-27-15.00.10.349880-480 I930031A600 LEVEL: Error\n"
+ "PID : 30868490 TID : 180042 PROC : db2sysc 0\n"
+ "INSTANCE: db2prd2 NODE : 000 DB : PRODDW_2\n"
+ "APPHDL : 0-55088 APPID: 170.2.78.74.45949.200127223832\n"
+ "UOWID : 101 ACTID: 1\n"
+ "AUTHID : DWFLDREP HOSTNAME: db2udb04.us164.corpintra.net\n"
+ "EDUID : 180042 EDUNAME: db2agnts (PRODDW_2) 0\n"
+ "FUNCTION: DB2 UDB, runtime interpreter, sqlrisrt, probe:3312\n"
+ "DATA #2 : Hexdump, 4 bytes\n"
+ "0x0A000000A83FD4C4 : 800F 0003 ....";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}