# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?ms)LEVEL:\s+(?<LEVEL>.*)PID\s+:\s(?<PID>\d+)\s+TID\s:\s+(?<TID>\d+)\s+PROC\s+:\s+(?<PROC>\w+)\s+\d+\s+INSTANCE:\s+(?<INSTANCE>\w+)\s+NODE\s+:\s+(?<NODE>\d+)\s+DB\s+:\s+(?<DB>\w+)\s+APPHDL\s+:\s+(?<APPHDL>[^ ]+)\s+APPID:\s+(?<APPID>[^ ]+)UOWID\s+:\s+(?<UOWID>\d+)\s+ACTID:\s+(?<ACTID>\d+)\s+AUTHID\s+:\s+\w+\s+HOSTNAME:\s+(?<HOSTNAME>[^ ]+)\s+EDUID\s+:\s+(?<EDUID>\d+)\s+EDUNAME:\s+(?<EDUNAME>.*)\s+FUNCTION:\s+(?<FUNCTION>\w+)"
test_str = ("2020-01-27-15.00.10.349880-480 I930031A600 LEVEL: Error\n"
"PID : 30868490 TID : 180042 PROC : db2sysc 0\n"
"INSTANCE: db2prd2 NODE : 000 DB : PRODDW_2\n"
"APPHDL : 0-55088 APPID: 170.2.78.74.45949.200127223832\n"
"UOWID : 101 ACTID: 1\n"
"AUTHID : DWFLDREP HOSTNAME: db2udb04.us164.corpintra.net\n"
"EDUID : 180042 EDUNAME: db2agnts (PRODDW_2) 0\n"
"FUNCTION: DB2 UDB, runtime interpreter, sqlrisrt, probe:3312\n"
"DATA #2 : Hexdump, 4 bytes\n"
"0x0A000000A83FD4C4 : 800F 0003 ....")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.