use strict;
my $str = 'ID=6913&Filename=C%3A%5CUsers%5CTHanse04%5CAppData%5CRoaming%5CDocumentum%5CViewed%5C181019_ERS_321_102_500857.pdf&Download=65536&DownloadSize=79243& HTTP/1.1" 200 3 "-" "Java/1.8.0_192';
my $regex = qr/(?:Filename=)(.*)(\.pdf)(?:&)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";