# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[,\"])\b(?P<HostName>\w+)(?=,Default)"
test_str = ("\"2018-12-12 13:25:30\",\"Renju, Jacob,M(renjutest)\",\"Renju, Jacob, M (rtest),Renju123,Default Site,Test/firewall\",\"10.221.5.136\",\"XXX.XXX.XXX.XXX\",\"Allowed\",\"16 (A)\",\"NOERROR\",\"1XX.1X.1XX.1XX.Test.com.\",\"Computer Security\"\n\n"
"\"2018-12-12 13:09:55\",\"rtest\",\"Renju123,Default Site,Renju Renju/Renju\",\"10.250.33.85\",\"XXX.XXX.XXX.XXX\",\"Allowed\",\"12 (PTR)\",\"NOERROR\",\"1XX.1X.1XX.1XX.Test.com.\",\"Software/Technology\"\n\n\n"
"\"2018-12-12 14:29:49\",\"Default Site\",\"Renju Test/Firewal,Default Site\",\"10.250.33.8\",\"1XX.1X.1XX.1XX.Test.com\",\"Allowed\",\"28 (AAAA)\",\"NXDOMAIN\",\"targets.\",\"\".\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.