package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d{3}-\d{2}-\d{4})|(\d{3}\d{2}\d{4})$`)
var str = `199-25-6936
897898745
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}