$re = '/^(\d{3}-\d{2}-\d{4})|(\d{3}\d{2}\d{4})$/';
$str = '199-25-6936
897898745
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);