use strict;
my $str = 'This is a estoppel page
<a href=\'https://sample.com/the-estoppel/\' class="exclude-link" target="_blank" rel="noopener">Chapter 1 – The effect of promissory estoppel.</a>
This line contains estoppel and default';
my $regex = qr~<a.*?</a>|^.*\bdefault\b.*$|\b(estoppel)\b~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}