$re = '~<a.*?</a>|^.*\bdefault\b.*$|\b(estoppel)\b~m';
$str = 'This is a estoppel page
<a href=\'https://sample.com/the-estoppel/\' class="exclude-link" target="_blank" rel="noopener">Chapter 1 – The effect of promissory estoppel.</a>
This line contains estoppel and default';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);