const regex = /---\n ((?!---|hostname:) [^\n]+? (\n|$))+ hostname:[^\n]+.domain.com(\n|$) ((?!---|hostname:) [^\n]+? (\n|$))+ (?=---|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('---\\n ((?!---|hostname:) [^\\n]+? (\\n|$))+ hostname:[^\\n]+.domain.com(\\n|$) ((?!---|hostname:) [^\\n]+? (\\n|$))+ (?=---|$)', 'g')
const str = `---
event: outgoing HTTP response
timestamp: 2021-10-06T08:15:28.212Z
remoteAddress: "1.2.3.4"
hostname: a.b.c.domain.com
statusCode: 200
headers:
content-length: 524
etc: ...
body: "blabla (can be multiline and can contain anything)"
---
event: outgoing HTTP response
timestamp: 2021-10-06T08:15:28.212Z
remoteAddress: "1.2.3.4"
hostname: a.b.c.different.com
statusCode: 200
headers:
content-length: 524
etc: ...
body: "blabla (can be multiline and can contain anything)"
---
event: outgoing HTTP response
timestamp: 2021-10-06T08:15:28.212Z
remoteAddress: "1.2.3.4"
hostname: 1.2.3.domain.com
statusCode: 200
headers:
content-length: 524
etc: ...
body: "blabla (can be multiline and can contain anything)"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}