# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
---\n ((?!---|hostname:) [^\n]+? (\n|$))+ hostname:[^\n]+.domain.com(\n|$) ((?!---|hostname:) [^\n]+? (\n|$))+ (?=---|$)
"""
test_str = ("---\n"
"event: outgoing HTTP response\n"
"timestamp: 2021-10-06T08:15:28.212Z\n"
"remoteAddress: \"1.2.3.4\"\n"
"hostname: a.b.c.domain.com\n"
"statusCode: 200\n"
"headers:\n"
" content-length: 524\n"
" etc: ...\n"
"body: \"blabla (can be multiline and can contain anything)\"\n"
"---\n"
"event: outgoing HTTP response\n"
"timestamp: 2021-10-06T08:15:28.212Z\n"
"remoteAddress: \"1.2.3.4\"\n"
"hostname: a.b.c.different.com\n"
"statusCode: 200\n"
"headers:\n"
" content-length: 524\n"
" etc: ...\n"
"body: \"blabla (can be multiline and can contain anything)\"\n"
"---\n"
"event: outgoing HTTP response\n"
"timestamp: 2021-10-06T08:15:28.212Z\n"
"remoteAddress: \"1.2.3.4\"\n"
"hostname: 1.2.3.domain.com\n"
"statusCode: 200\n"
"headers:\n"
" content-length: 524\n"
" etc: ...\n"
"body: \"blabla (can be multiline and can contain anything)\"")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.