using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*pet).*";
string input = @"""/pet"",
""/pet/findByStatus"",
""/pet/findByTags"",
""/pet/{petId}"",
""/pet/{petId}/uploadImage"",
""/store/inventory"",
""/store/order"",
""/store/order/{orderId}"",
""/user"",
""/user/createWithArray"",
""/user/createWithList"",
""/user/login"",
""/user/logout"",
""/user/{username}""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}