import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*pet).*";
final String string = "\"/pet\",\n"
+ "\"/pet/findByStatus\",\n"
+ "\"/pet/findByTags\",\n"
+ "\"/pet/{petId}\",\n"
+ "\"/pet/{petId}/uploadImage\",\n"
+ "\"/store/inventory\",\n"
+ "\"/store/order\",\n"
+ "\"/store/order/{orderId}\",\n"
+ "\"/user\",\n"
+ "\"/user/createWithArray\",\n"
+ "\"/user/createWithList\",\n"
+ "\"/user/login\",\n"
+ "\"/user/logout\",\n"
+ "\"/user/{username}\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}