package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)@?\b([A-Z0-9._%+-]+)@([A-Z0-9.-]+\.[A-Z]{2,})\b`)
var str = `@aendra@hackers.town
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}