re = /@?\b([A-Z0-9._%+-]+)@([A-Z0-9.-]+\.[A-Z]{2,})\b/mi
str = '@aendra@hackers.town
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end