$re = '/\d{4}\-(0?[1-9]|1[012])\-(0?[1-9]|[12][0-9]|3[01])*/';
$str = 'Bla bla bla 2017-12-12 bla bla bla lkasjdfklsad 2011-12-3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);