const regex = new RegExp('[^/P-`mvÇ-ıḃ-ṫ€]*', 'g')
const str = `’:2o1
Ḃ¬aẋ@0
’r0;0ẋ\$ẋ1Ŀ¬0¦;2ĿÆ¡œ?⁸²¤s⁸G`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}