re = /[\(\[]( \w+| (?R))+ ?[\)|\]]/m
str = '( A B )
[ C D ]
[ ( A B ) [ C A ] ]
( Alfa [ Charlie Delta ( Bravo [ Echo ( Foxtrot Golf ) ] ) ] )
( Alef [ ( Bet Bet Bet ) ( Vet [ ( Vet Vet ) ( Vet [ Bet Bet ] ) ] ) ] )
[ ( [ Star ( Star Star ) ] [ Star ( Star Star ) ] Star ) ( [ Star ( Star Star ) ] [ Star ( Star Star ) ] Star ) ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end