package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(20|21|22)$`)
var str = `20
21
22
25
27
220
222
121
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}