$re = '/^(20|21|22)$/m';
$str = '20
21
22
25
27
220
222
121
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);