$re = '/^IJfdm323PO={0,2}$/m';
$str = 'IJfdm323PO=======
IJfdm323PO=====
IJfdm323PO===
IJfdm323PO====
IJfdm323PO===
IJfdm323PO==
IJfdm323PO=
IJfdm323PO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);