re = /^IJfdm323PO={0,2}$/m
str = 'IJfdm323PO=======
IJfdm323PO=====
IJfdm323PO===
IJfdm323PO====
IJfdm323PO===
IJfdm323PO==
IJfdm323PO=
IJfdm323PO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end