import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(HL\\/)+HL$)|(^HLx\\d+$)|(^HL$)";
final String string = "Guard\n"
+ "HL/H\n"
+ "-\n"
+ "HL/HL\n"
+ "L/L\n"
+ "L/L\n"
+ "HL/HL\n"
+ "L/HL\n"
+ "HL/HL\n"
+ "L/HL\n"
+ "HL/HL/HL\n"
+ "L/HL/HL\n"
+ "HL/HL\n"
+ "HL/HL/HL\n"
+ "HL/HL/HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL/HL\n"
+ "HL/HL/HL\n"
+ "HL/HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL/L/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/H\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "LH/LH\n"
+ "L/H\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "LH/LH\n"
+ "L/H\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL/HL\n"
+ "HL/HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "(B+F)+LP+LK\n"
+ "(B/F)+LP+LK\n"
+ "LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "HL\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "LP+LK\n"
+ "-\n"
+ "-\n"
+ "-\n"
+ "F/B+LP+LK\n"
+ "F+LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "LP+LK\n"
+ "B+LP+LK on backturned opponent\n"
+ "HL\n"
+ "LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "B/F+LP+LK\n"
+ "LP+LK\n"
+ "LP+LK\n"
+ "LP+LK\n"
+ "LP+LK\n"
+ "LP+LK\n"
+ "LP+LK\n"
+ "=+\n"
+ "=+\n"
+ "LP+LK\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "LP+LK\n"
+ "HLx2\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "B+LP+LK\n"
+ "B/F+LP+LK\n"
+ "B/F+LP+LK\n"
+ "B/F+LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "LP+LK\n"
+ "Close to Oponnent On Air LP+LK\n"
+ "LP+LK\n"
+ "(F)+LP+LK\n"
+ "HL/HL/HL\n"
+ "HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "B+LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "(Air) LP+LK\n"
+ "LP+LK\n"
+ "LP+LK\n"
+ "B+LP+LK\n"
+ "LP+LK\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "LP+LK\n"
+ "(B/F)+LP+LK\n"
+ "H\n"
+ "F+LP+LK\n"
+ "HL\n"
+ "H/H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL/HL\n"
+ "HL/HL/HL\n"
+ "HL/HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HLx7\n"
+ "HL/HL/HL\n"
+ "HLx4\n"
+ "HLx3+HL/Lx3 Down\n"
+ "HL/HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "Impossible\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "Impossible\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "L\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL/HL\n"
+ "HL\n"
+ "-\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "Impossible\n"
+ "Impossible\n"
+ "Impossible\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HLx1~5\n"
+ "HLx1~5\n"
+ "HLx1~5\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "Impossible\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "Impossible\n"
+ "Impossible\n"
+ "Impossible\n"
+ "Impossible\n"
+ "Impossible\n"
+ "Impossible\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HL/HL/HL\n"
+ "HL/HL\n"
+ "Impossible\n"
+ "Impossible\n"
+ "Impossible\n"
+ "HL\n"
+ "Impossible\n"
+ "Impossible\n"
+ "Impossible\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "Hx2\n"
+ "HL\n"
+ "Hx2\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HLx4\n"
+ "HL\n"
+ "HL\n"
+ "HLx3\n"
+ "HL\n"
+ "L/HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "H\n"
+ "HLx2\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "HLx2\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H/H\n"
+ "H\n"
+ "HL/HL\n"
+ "HL/HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "HL/HL/HL\n"
+ "HL/H\n"
+ "L\n"
+ "HL/HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H(far) or L(close)\n"
+ "H\n"
+ "HLx2\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "-\n"
+ "HL\n"
+ "HL/HL/HL\n"
+ "HL/HL/HL\n"
+ "H\n"
+ "HL/HL/HL/HL\n"
+ "HL/HL/HL/HL/HL\n"
+ "H\n"
+ "HL/HL/HL\n"
+ "HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H/H\n"
+ "H/H\n"
+ "H/H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HL/HL/HL/HL\n"
+ "HL/HL/HL/HL/HL\n"
+ "HL/HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "-\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "HL/HL/HL/HL\n"
+ "-\n"
+ "H\n"
+ "HLx4\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H/H\n"
+ "H/H\n"
+ "H/H\n"
+ "Lx2\n"
+ "Lx4\n"
+ "Lx2\n"
+ "HL\n"
+ "HL\n"
+ "HL/HL\n"
+ "H/L\n"
+ "-\n"
+ "-\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL/HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "-\n"
+ "-\n"
+ "HL\n"
+ "HL/H/H\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H/H\n"
+ "H\n"
+ "HLx2\n"
+ "HLx1~5\n"
+ "HL/HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "H\n"
+ "HL/H/H\n"
+ "-\n"
+ "HL\n"
+ "Lx5\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HLx2\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "-\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HLx2\n"
+ "HLx2\n"
+ "HLx2\n"
+ "HLx3\n"
+ "HLx3\n"
+ "HLx3\n"
+ "-\n"
+ "-\n"
+ "-\n"
+ "HL\n"
+ "HL\n"
+ "L\n"
+ "HL\n"
+ "HL\n"
+ "HL/HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL/H/H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HLx2\n"
+ "HL/HL/HL\n"
+ "HLx2\n"
+ "HL\n"
+ "HLx2\n"
+ "HL/HL\n"
+ "HL\n"
+ "HLx2\n"
+ "Hx3\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "-\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL/HL/HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H/H\n"
+ "HL\n"
+ "HL\n"
+ "HLx2\n"
+ "L\n"
+ "L\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "L\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HLx2\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "Impossible\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HLx2\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "HL\n"
+ "H\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "HL\n"
+ "H\n"
+ "H\n"
+ "H\n"
+ "-\n"
+ "H\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}