$re = '/^(?:(?!nicht|NICHT).)*\d+.jpg$/m';
$str = 'asdhoho123.jpg
asdhihi123.jpg
asdhede123.jpg
asdhaha123.jpg
asdhede123.jpg
file001.jpg
fileNICHT01.jpg
file002.jpg
filenicht02.jpg
wurst012.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);