import Foundation
let pattern = #"^(?:(?!nicht|NICHT).)*\d+.jpg$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
asdhoho123.jpg
asdhihi123.jpg
asdhede123.jpg
asdhaha123.jpg
asdhede123.jpg
file001.jpg
fileNICHT01.jpg
file002.jpg
filenicht02.jpg
wurst012.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)