package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?imU)^"the[^@]*fox[^@]*lazy[^@]*"$`)
var str = `"the quick brown fox
jumped over the lazy dog"
this string should not be selected
this string should not be selected
"the quick brown fox
jumped over the lazy dog"
"the quick brown fox jumped over the lazy dog"
this string should not be selected
the quick brown fox
jumped over the lazy dog
the quick brown fox jumped over the lazy dog
this string should not be selected`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}