$re = '/^"the[^@]*fox[^@]*lazy[^@]*"$/imU';
$str = '"the quick brown fox
jumped over the lazy dog"
this string should not be selected
this string should not be selected
"the quick brown fox
jumped over the lazy dog"
"the quick brown fox jumped over the lazy dog"
this string should not be selected
the quick brown fox
jumped over the lazy dog
the quick brown fox jumped over the lazy dog
this string should not be selected';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);