#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(([0-9a-fA-F]{1,4}:){7,7}[0-9a-fA-F]{1,4}|" & @CRLF & _
"([0-9a-fA-F]{1,4}:){1,7}:|" & @CRLF & _
"([0-9a-fA-F]{1,4}:){1,6}:[0-9a-fA-F]{1,4}|" & @CRLF & _
"([0-9a-fA-F]{1,4}:){1,5}(:[0-9a-fA-F]{1,4}){1,2}|" & @CRLF & _
"([0-9a-fA-F]{1,4}:){1,4}(:[0-9a-fA-F]{1,4}){1,3}|" & @CRLF & _
"([0-9a-fA-F]{1,4}:){1,3}(:[0-9a-fA-F]{1,4}){1,4}|" & @CRLF & _
"([0-9a-fA-F]{1,4}:){1,2}(:[0-9a-fA-F]{1,4}){1,5}|" & @CRLF & _
"[0-9a-fA-F]{1,4}:((:[0-9a-fA-F]{1,4}){1,6})|" & @CRLF & _
":((:[0-9a-fA-F]{1,4}){1,7}|:)|" & @CRLF & _
"fe80:(:[0-9a-fA-F]{0,4}){0,4}%[0-9a-zA-Z]{1,}|" & @CRLF & _
"::(ffff(:0{1,4}){0,1}:){0,1}" & @CRLF & _
"((25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])\.){3,3}" & @CRLF & _
"(25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])|" & @CRLF & _
"([0-9a-fA-F]{1,4}:){1,4}:" & @CRLF & _
"((25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])\.){3,3}" & @CRLF & _
"(25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9]))" & @CRLF & _
"|((25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])\.){3,3}(25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])"
Local $sString = "3ffe:1900:4545:3:200:f8ff:fe21:67cf" & @CRLF & _
"fe80:0:0:0:200:f8ff:fe21:67cf" & @CRLF & _
"192.168.0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")