# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(([0-9a-fA-F]{1,4}:){7,7}[0-9a-fA-F]{1,4}|\n"
r"([0-9a-fA-F]{1,4}:){1,7}:|\n"
r"([0-9a-fA-F]{1,4}:){1,6}:[0-9a-fA-F]{1,4}|\n"
r"([0-9a-fA-F]{1,4}:){1,5}(:[0-9a-fA-F]{1,4}){1,2}|\n"
r"([0-9a-fA-F]{1,4}:){1,4}(:[0-9a-fA-F]{1,4}){1,3}|\n"
r"([0-9a-fA-F]{1,4}:){1,3}(:[0-9a-fA-F]{1,4}){1,4}|\n"
r"([0-9a-fA-F]{1,4}:){1,2}(:[0-9a-fA-F]{1,4}){1,5}|\n"
r"[0-9a-fA-F]{1,4}:((:[0-9a-fA-F]{1,4}){1,6})|\n"
r":((:[0-9a-fA-F]{1,4}){1,7}|:)|\n"
r"fe80:(:[0-9a-fA-F]{0,4}){0,4}%[0-9a-zA-Z]{1,}|\n"
r"::(ffff(:0{1,4}){0,1}:){0,1}\n"
r"((25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])\.){3,3}\n"
r"(25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])|\n"
r"([0-9a-fA-F]{1,4}:){1,4}:\n"
r"((25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])\.){3,3}\n"
r"(25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9]))\n"
r"|((25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])\.){3,3}(25[0-5]|(2[0-4]|1{0,1}[0-9]){0,1}[0-9])")
test_str = ("3ffe:1900:4545:3:200:f8ff:fe21:67cf\n"
"fe80:0:0:0:200:f8ff:fe21:67cf\n"
"192.168.0.1")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.