$re = '/(?:abc\s*\(\s*|\G(?!^),)(\'[^\',]*\'|\w+\([^()]*\))/m';
$str = 'and abc ( xyz(d.e),\'f\',\'g\',\'h\',\'i\',abc(\'p/q\'),\'r\') = u';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);