re = /(?:abc\s*\(\s*|\G(?!^),)('[^',]*'|\w+\([^()]*\))/m
str = 'and abc ( xyz(d.e),\'f\',\'g\',\'h\',\'i\',abc(\'p/q\'),\'r\') = u'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end