re = /img\.shields\.io\/static\/v1\.svg\?label=PyCalVer&message=(?P<pycalver>v(?P<year>\d{4})(?P<month>(?:0[0-9]|1[0-2]))\.(?P<bid>\d{4,})(?:-(?P<tag>(?:alpha|beta|dev|rc|post|final)))?)&color=blue/m
str = '
[version_img]: https://img.shields.io/static/v1.svg?label=PyCalVer?message=v201902.0025&color=blue
[version_img]: https://img.shields.io/static/v1.svg?label=PyCalVer&message=v201902.0025&color=blue'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end