// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)img\.shields\.io/static/v1\.svg\?label=PyCalVer&message=(?P<pycalver>v(?P<year>\d{4})(?P<month>(?:0[0-9]|1[0-2]))\.(?P<bid>\d{4,})(?:-(?P<tag>(?:alpha|beta|dev|rc|post|final)))?)&color=blue").unwrap();
let string = "
[version_img]: https://img.shields.io/static/v1.svg?label=PyCalVer?message=v201902.0025&color=blue
[version_img]: https://img.shields.io/static/v1.svg?label=PyCalVer&message=v201902.0025&color=blue";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}