#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z][A-Ha-hJ-Yj-y]?[0-9][A-Za-z0-9]? ?[0-9][A-Za-z]{2}|[Gg][Ii][Rr] ?0[Aa]{2})$"
Local $sString = "A1A 1AA" & @CRLF & _
"A1 1AA" & @CRLF & _
"A11 1AA" & @CRLF & _
"AA1 1AA" & @CRLF & _
"AA1A 1AA" & @CRLF & _
"AA11 1AA" & @CRLF & _
"A1A1AA" & @CRLF & _
"A11AA" & @CRLF & _
"A111AA" & @CRLF & _
"AA11AA" & @CRLF & _
"AA1A1AA" & @CRLF & _
"AA111AA" & @CRLF & _
"GIR 0AA" & @CRLF & _
"GIR0AA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")