import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z][A-Ha-hJ-Yj-y]?[0-9][A-Za-z0-9]? ?[0-9][A-Za-z]{2}|[Gg][Ii][Rr] ?0[Aa]{2})$";
final String string = "A1A 1AA\n"
+ "A1 1AA\n"
+ "A11 1AA\n"
+ "AA1 1AA\n"
+ "AA1A 1AA\n"
+ "AA11 1AA\n"
+ "A1A1AA\n"
+ "A11AA\n"
+ "A111AA\n"
+ "AA11AA\n"
+ "AA1A1AA\n"
+ "AA111AA\n"
+ "GIR 0AA\n"
+ "GIR0AA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}