import re
regex = re.compile(r"^([A-Z][A-HJ-Y]?[0-9][A-Z0-9]? ?[0-9][A-Z]{2}|GIR ?0A{2})$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("A1A 1AA\n"
"A1 1AA\n"
"A11 1AA\n"
"AA1 1AA\n"
"AA1A 1AA\n"
"AA11 1AA\n"
"A1A1AA\n"
"A11AA\n"
"A111AA\n"
"AA11AA\n"
"AA1A1AA\n"
"AA111AA\n"
"GIR 0AA\n"
"GIR0AA\n"
"a1a 1aa\n"
"a1 1aa\n"
"a11 1aa\n"
"aa1 1aa\n"
"aa1a 1aa\n"
"aa11 1aa\n"
"a1a1aa\n"
"a11aa\n"
"a111aa\n"
"aa11aa\n"
"aa1a1aa\n"
"aa111aa\n"
"gir 0aa\n"
"gir0aa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")