#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([A-Z]{1,2}\d[A-Z\d]? ?\d[A-Z]{2}|GIR ?0A{2})$"
Local $sString = "A1A 1AA" & @CRLF & _
"A1 1AA" & @CRLF & _
"A11 1AA" & @CRLF & _
"AA1 1AA" & @CRLF & _
"AA1A 1AA" & @CRLF & _
"AA11 1AA" & @CRLF & _
"A1A1AA" & @CRLF & _
"A11AA" & @CRLF & _
"A111AA" & @CRLF & _
"AA11AA" & @CRLF & _
"AA1A1AA" & @CRLF & _
"AA111AA" & @CRLF & _
"GIR 0AA" & @CRLF & _
"GIR0AA" & @CRLF & _
"a1a 1aa" & @CRLF & _
"a1 1aa" & @CRLF & _
"a11 1aa" & @CRLF & _
"aa1 1aa" & @CRLF & _
"aa1a 1aa" & @CRLF & _
"aa11 1aa" & @CRLF & _
"a1a1aa" & @CRLF & _
"a11aa" & @CRLF & _
"a111aa" & @CRLF & _
"aa11aa" & @CRLF & _
"aa1a1aa" & @CRLF & _
"aa111aa" & @CRLF & _
"gir 0aa" & @CRLF & _
"gir0aa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")