$re = '/^([A-Z]{1,2}\d[A-Z\d]? ?\d[A-Z]{2}|GIR ?0A{2})$/mi';
$str = 'A1A 1AA
A1 1AA
A11 1AA
AA1 1AA
AA1A 1AA
AA11 1AA
A1A1AA
A11AA
A111AA
AA11AA
AA1A1AA
AA111AA
GIR 0AA
GIR0AA
a1a 1aa
a1 1aa
a11 1aa
aa1 1aa
aa1a 1aa
aa11 1aa
a1a1aa
a11aa
a111aa
aa11aa
aa1a1aa
aa111aa
gir 0aa
gir0aa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);