import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([A-Z]{1,2}\\d[A-Z\\d]?|ASCN|STHL|TDCU|BBND|[BFS]IQQ|PCRN|TKCA) ?\\d[A-Z]{2}|BFPO ?\\d{1,4}|(KY\\d|MSR|VG|AI)[ -]?\\d{4}|[A-Z]{2} ?\\d{2}|GE ?CX|GIR ?0A{2}|SAN ?TA1)$";
final String string = "AI-1111\n"
+ "ASCN 1ZZ\n"
+ "STHL 1ZZ\n"
+ "TDCU 1ZZ\n"
+ "BBND 1ZZ\n"
+ "BIQQ 1ZZ\n"
+ "FIQQ 1ZZ\n"
+ "GX11 1ZZ\n"
+ "PCRN 1ZZ\n"
+ "SIQQ 1ZZ\n"
+ "TKCA 1ZZ\n"
+ "BFPO 11\n"
+ "ZZ 11\n"
+ "GE CX\n"
+ "KY1-1111\n"
+ "VG1111\n"
+ "MSR 1111\n"
+ "A1A 1AA\n"
+ "A1 1AA\n"
+ "A11 1AA\n"
+ "AA1 1AA\n"
+ "AA1A 1AA\n"
+ "AA11 1AA\n"
+ "A1A1AA\n"
+ "A11AA\n"
+ "A111AA\n"
+ "AA11AA\n"
+ "AA1A1AA\n"
+ "AA111AA\n"
+ "GIR 0AA\n"
+ "GIR0AA\n"
+ "BFPO 1\n"
+ "BFPO 11\n"
+ "BFPO 111\n"
+ "BFPO 1111\n"
+ "SAN TA1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}