import re
regex = re.compile(r"^(([A-Z]{1,2}\d[A-Z\d]?|ASCN|STHL|TDCU|BBND|[BFS]IQQ|PCRN|TKCA) ?\d[A-Z]{2}|BFPO ?\d{1,4}|(KY\d|MSR|VG|AI)[ -]?\d{4}|[A-Z]{2} ?\d{2}|GE ?CX|GIR ?0A{2}|SAN ?TA1)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("AI-1111\n"
"ASCN 1ZZ\n"
"STHL 1ZZ\n"
"TDCU 1ZZ\n"
"BBND 1ZZ\n"
"BIQQ 1ZZ\n"
"FIQQ 1ZZ\n"
"GX11 1ZZ\n"
"PCRN 1ZZ\n"
"SIQQ 1ZZ\n"
"TKCA 1ZZ\n"
"BFPO 11\n"
"ZZ 11\n"
"GE CX\n"
"KY1-1111\n"
"VG1111\n"
"MSR 1111\n"
"A1A 1AA\n"
"A1 1AA\n"
"A11 1AA\n"
"AA1 1AA\n"
"AA1A 1AA\n"
"AA11 1AA\n"
"A1A1AA\n"
"A11AA\n"
"A111AA\n"
"AA11AA\n"
"AA1A1AA\n"
"AA111AA\n"
"GIR 0AA\n"
"GIR0AA\n"
"BFPO 1\n"
"BFPO 11\n"
"BFPO 111\n"
"BFPO 1111\n"
"SAN TA1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")