#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?P<error_msg>.*?)(?:exit\s+code:\s+)(?P<exit_code>\d+).(?:Stdout:)(?P<stdout>.*?)(?:Stderr:)(?P<stderr>.*?)(?:CUSTOM_EOF)"
Local $sString = "process "pipenv run pylint --rcfile .linting-configs/pylintrc ci/dagger/automation.py ci/dagger/async_interface.py ci/dagger/models/linting.py ci/dagger/models/config.py ci/dagger/linting.py ci/dagger/helper.py" did not complete successfully: exit code: 28" & @CRLF & _
"Stdout:" & @CRLF & _
"o snake_case naming style (invalid-name)" & @CRLF & _
"************* Module models.linting" & @CRLF & _
"ci/dagger/models/linting.py:9:0: C0115: Missing class docstring (missing-class-docstring)" & @CRLF & _
"ci/dagger/models/linting.py:15:22: C0103: Argument name "v" doesn't conform to snake_case naming style (invalid-name)" & @CRLF & _
"ci/dagger/models/linting.py:33:0: C0115: Missing class docstring (missing-class-docstring)" & @CRLF & _
"ci/dagger/models/linting.py:44:4: C0115: Missing class docstring (missing-class-docstring)" & @CRLF & _
"ci/dagger/models/linting.py:44:4: R0903: Too few public methods (0/2) (too-few-public-methods)" & @CRLF & _
"ci/dagger/models/linting.py:33:0: R0903: Too few public methods (1/2) (too-few-public-methods)" & @CRLF & _
"ci/dagger/models/linting.py:48:0: C0115: Missing class docstring (missing-class-docstring)" & @CRLF & _
"************* Module models.config" & @CRLF & _
"ci/dagger/models/config.py:6:0: C0115: Missing class docstring (missing-class-docstring)" & @CRLF & _
"ci/dagger/models/config.py:6:0: R0903: Too few public methods (0/2) (too-few-public-methods)" & @CRLF & _
"************* Module linting" & @CRLF & _
"ci/dagger/linting.py:37:4: W0613: Unused argument 'client' (unused-argument)" & @CRLF & _
"ci/dagger/linting.py:179:4: W0613: Unused argument 'client' (unused-argument)" & @CRLF & _
"ci/dagger/linting.py:240:4: W0613: Unused argument 'client' (unused-argument)" & @CRLF & _
"ci/dagger/linting.py:301:4: W0613: Unused argument 'client' (unused-argument)" & @CRLF & _
"ci/dagger/linting.py:5:0: W0611: Unused import click (unused-import)" & @CRLF & _
"ci/dagger/linting.py:7:0: W0611: Unused QueryError imported from dagger.exceptions (unused-import)" & @CRLF & _
"************* Module helper" & @CRLF & _
"ci/dagger/helper.py:51:0: C0116: Missing function or method docstring (missing-function-docstring)" & @CRLF & _
"ci/dagger/helper.py:88:0: C0115: Missing class docstring (missing-class-docstring)" & @CRLF & _
"ci/dagger/helper.py:122:0: C0116: Missing function or method docstring (missing-function-docstring)" & @CRLF & _
"ci/dagger/helper.py:133:19: W0212: Access to a protected member _raw_input of a client class (protected-access)" & @CRLF & _
"ci/dagger/helper.py:1:0: W0611: Unused getenv imported from os (unused-import)" & @CRLF & _
"" & @CRLF & _
"-----------------------------------" & @CRLF & _
"Your code has been rated at 8.45/10" & @CRLF & _
"Stderr:" & @CRLF & _
"CUSTOM_EOF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")