import re
regex = re.compile(r"(fopen|fwrite)\([^$]*(,|\))", flags=re.IGNORECASE | re.MULTILINE | re.DOTALL)
test_str = ("fopen($file)\n"
"fopen($file, 'w')\n"
"fopen(\"file\" . $file)\n"
"$fp = fopen(\n"
" $file\n"
")\n\n"
"$data = base64_encode(fread(fopen($val, \"r\"), filesize($val)));\n\n"
"fopen(\"file\", $w)\n"
"fopen(\"file\")\n"
"$fp = fopen(\n"
" \"file\"\n"
")\n"
"$curlResult = fopen(\"/app/localhost/html/curlResult.txt\", \"r\") or die (\"unable to find\");")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")