import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*\\.{2})^(?![^@]{11})([a-z\\d!#$%&'*+\\-\\/=?^_`\\{|\\}~\\u00A0]+(\\.[a-z\\d!#$%&'*+\\-\\/=?^_`\\{|\\}~\\u00A0]+)*|\"((([ \\t]*\\r\\n)?[ \\t]+)?([\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x7f\\x21\\x23-\\x5b\\x5d-\\x7e\\u00A0]|\\\\[\\x01-\\x09\\x0b\\x0c\\x0d-\\x7f\\u00A0]))*(([ \\t]*\\r\\n)?[ \\t]+)?\")@(([a-z\\d\\u00A0]|[a-z\\d\\u00A0][a-z\\d\\-._~\\u00A0]*[a-z\\d\\u00A0])\\.)+([a-z\\u00A0]|[a-z\\u00A0][a-z\\d\\-._~\\u00A0]*[a-z\\u00A0])\\.?$";
final String string = "abc@google.com\n"
+ "abcdefghij@google.com\n"
+ "abcdefghijk@google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}