const regex = /^(?:ach\sdebit\s|point\sof\ssale\sdebit\s)?(?:l\d{3}\s)?(?:TIME\s\d\d:\d\d\s[A|P]M\s*)?(?:DATE\s\d\d-\d\d\s)?([a-z-*'\s]+)(?:[\d\s]{15,}|\d{3}-?\d{3}-?\d{4}|#\w+)?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:ach\\sdebit\\s|point\\sof\\ssale\\sdebit\\s)?(?:l\\d{3}\\s)?(?:TIME\\s\\d\\d:\\d\\d\\s[A|P]M\\s*)?(?:DATE\\s\\d\\d-\\d\\d\\s)?([a-z-*\'\\s]+)(?:[\\d\\s]{15,}|\\d{3}-?\\d{3}-?\\d{4}|#\\w+)?', 'gmi')
const str = `ACH Debit 5/3 MORTGAGE LN PAYMENT 017136000924355
Point of Sale Debit L340 TIME 08:37 AM DATE 04-26 JR GENERAL STORE CHARLOTTE NC
Point of Sale Debit L343 TIME 07:02 PM DATE 04-25 AUTOZONE 4982 35CONCORD NC
Point of Sale Debit L343 TIME 07:00 PM DATE 04-25 AUTOZONE 4982 35CONCORD NC
Point of Sale Debit L340 DATE 04-25 ASF*ATA KARATE OF 800-5258967
ACH Debit GS Home Imp Fin 8669360602 017116001434401
Point of Sale Debit L343 TIME 07:56 AM DATE 04-27 AUTOZONE 4982 35CONCORD NC
Point of Sale Debit L340 DATE 04-25 CHICK-FIL-A #01118CONCORD
Point of Sale Debit L340 DATE 04-26 ANGELAS CONCORD
Point of Sale Debit L340 DATE 04-25 ATA KARATE CONCORDCONCORD
Check INCLEARING CHECK
Point of Sale Debit L341 TIME 03:52 PM DATE 04-27 HARRIS TE 358 GEOCONCORD NC
Point of Sale Debit L341 TIME 08:57 AM DATE 04-28 WALGREENS STORE 1CHARLOTTE NC
Point of Sale Debit L340 DATE 04-26 CHICK-FIL-A #01118CONCORD
Point of Sale Debit L340 DATE 04-27 HT EXPRESS LANE #6CONCORD
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}