# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:ach\sdebit\s|point\sof\ssale\sdebit\s)?(?:l\d{3}\s)?(?:TIME\s\d\d:\d\d\s[A|P]M\s*)?(?:DATE\s\d\d-\d\d\s)?([a-z-*'\s]+)(?:[\d\s]{15,}|\d{3}-?\d{3}-?\d{4}|#\w+)?"
test_str = ("ACH Debit 5/3 MORTGAGE LN PAYMENT 017136000924355\n"
"Point of Sale Debit L340 TIME 08:37 AM DATE 04-26 JR GENERAL STORE CHARLOTTE NC\n"
"Point of Sale Debit L343 TIME 07:02 PM DATE 04-25 AUTOZONE 4982 35CONCORD NC\n"
"Point of Sale Debit L343 TIME 07:00 PM DATE 04-25 AUTOZONE 4982 35CONCORD NC\n"
"Point of Sale Debit L340 DATE 04-25 ASF*ATA KARATE OF 800-5258967\n"
"ACH Debit GS Home Imp Fin 8669360602 017116001434401\n"
"Point of Sale Debit L343 TIME 07:56 AM DATE 04-27 AUTOZONE 4982 35CONCORD NC\n"
"Point of Sale Debit L340 DATE 04-25 CHICK-FIL-A #01118CONCORD\n"
"Point of Sale Debit L340 DATE 04-26 ANGELAS CONCORD\n"
"Point of Sale Debit L340 DATE 04-25 ATA KARATE CONCORDCONCORD\n"
"Check INCLEARING CHECK\n"
"Point of Sale Debit L341 TIME 03:52 PM DATE 04-27 HARRIS TE 358 GEOCONCORD NC\n"
"Point of Sale Debit L341 TIME 08:57 AM DATE 04-28 WALGREENS STORE 1CHARLOTTE NC\n"
"Point of Sale Debit L340 DATE 04-26 CHICK-FIL-A #01118CONCORD\n"
"Point of Sale Debit L340 DATE 04-27 HT EXPRESS LANE #6CONCORD\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.