package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{3}-\d{8}|\d{4}-\d{7}`)
var str = `0341-86091234`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}