$re = '/\d{3}-\d{8}|\d{4}-\d{7}/';
$str = '0341-86091234';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);