package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@(?:import|plugin)\s+["']([^"']+)["']`)
var str = `@import "tailwindcss";
@plugin "@tailwindcss/typography";
@plugin "daisyui";
@plugin "@iconify/tailwind4";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}